Recovery continues to progress, with the remaining backlog steadily decreasing. Additional optimisations implemented in the EU environment are supporting backlog processing effectively. Our teams continue to closely monitor recovery progress and will provide further updates as appropriate.
Posted Sep 19, 2026 - 04:07 PDT
Update
Recovery efforts continue in EU, and technical teams are observing ongoing reduction of the remaining backlog.
Additional recovery optimizations have been implemented to support backlog processing in EU, and technical teams continue to monitor throughput and overall recovery progress.
Further updates will be provided as progress continues.
Posted Sep 18, 2026 - 14:55 PDT
Update
Backlog recovery has completed in APAC following the previously implemented remediation, and inventory data processing has returned to expected levels in the region.
Recovery activities continue in EU, where technical teams are monitoring processing throughput and backlog reduction. Additional recovery measures are being evaluated to support backlog processing as recovery progresses.
Posted Sep 18, 2026 - 12:49 PDT
Update
Inventory data processing continues following the previously implemented remediation. Technical teams are actively monitoring processing throughput and backlog recovery across the affected environments.
Technical teams are continuing to assess recovery progress and any additional actions that may help accelerate backlog processing. Further updates will be provided as recovery progresses.
Posted Sep 18, 2026 - 11:52 PDT
Monitoring
Inventory data processing continues to recover, and technical teams are observing a downward trend in backlog volume. Additional processing capacity remains in place, and recovery progress is being closely monitored across the affected environments.
We will continue to monitor backlog reduction and provide further updates as recovery progresses.
Posted Sep 18, 2026 - 07:39 PDT
Update
Technical teams have completed the required configuration updates, and inventory data continues to be processed successfully.
Additional processing capacity has been allocated to accelerate backlog recovery, and technical teams are actively monitoring throughput and backlog reduction across the affected environments.
Recovery activities remain in progress, and further updates will be provided as backlog processing continues.
Posted Sep 18, 2026 - 07:34 PDT
Identified
Our technical teams have traced the issue to a recent deployment and have implemented remediation actions. Initial validation indicates inventory processing has resumed, and technical teams are actively monitoring processing activity and backlog recovery.
We are continuing to validate recovery across the affected environments and will provide further updates as more information becomes available.
Posted Sep 18, 2026 - 06:50 PDT
Investigating
Incident Description: We are investigating an issue affecting inventory data processing in the EU and APAC production environments. Customers may observe delays in inventory updates, resulting in inventory data not reflecting the most recent import activity.
Priority: P2
Restoration Activity: Our technical teams are actively investigating the issue, validating the scope of impact, and working with relevant dependencies to restore normal inventory processing. Further updates will be provided as more information becomes available.
Posted Sep 18, 2026 - 06:03 PDT
This incident affects: Flexera One - IT Asset Management - Europe (IT Asset Management - EU Inventory Upload) and Flexera One - IT Asset Management - APAC (IT Asset Management - APAC Inventory Upload).