First and Final Notification: Flexera One SaaS Manager – NAM – Application Access Disruption

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One SaaS Manager – NAM – Application Access Disruption

Timeframe: April 29, 2026, 3:00 AM PDT – April 29, 2026, 7:30 AM PDT

Incident Summary

On April 29, 2026, at approximately 3:00 AM PDT, an issue was identified affecting access to Flexera One SaaS Manager in the North America production environment.

During this period, affected customers were unable to access SaaS Manager. The issue impacted most customer tenants in the NAM region and was related to an internal SaaS Manager configuration update process that did not complete as expected for affected organizations.

Technical teams investigated the issue and identified that a high volume of internal SaaS Manager configuration updates had been triggered for customer organizations within a short period of time. These updates did not complete within the expected timeframe, causing affected organizations to remain in an updating state and preventing access to SaaS Manager.

As part of the recovery effort, technical teams increased processing capacity for the affected update process and worked through the pending configuration updates. Once the pending updates were completed, affected organizations were no longer in an updating state and access to SaaS Manager was restored.

By April 29, 2026, at approximately 7:30 AM PDT, access had been restored for affected customers. Following validation that SaaS Manager access had returned to expected operation, the incident was considered resolved.

Root Cause

The incident was caused by a high volume of internal SaaS Manager configuration updates for customer organizations that did not complete within the expected timeframe. While these updates remained pending, affected customer organizations were left in an updating state, which prevented access to SaaS Manager during the incident window.

Remediation Actions

The following actions were taken during the incident response:

  1. Incident Investigation Initiated: Technical teams began investigating reports of SaaS Manager access issues affecting customers in the North America region.
  2. Impact Scope Reviewed: The issue was confirmed to affect most customer tenants in the NAM region.
  3. Configuration Update Processing Reviewed: Technical teams identified that a high volume of internal SaaS Manager configuration updates had been triggered and were not completing within the expected timeframe.
  4. Processing Capacity Increased: Technical teams increased processing capacity for the affected update process to help complete the pending configuration updates.
  5. Pending Updates Completed: The pending configuration updates were processed for affected organizations.
  6. Access Restoration Completed: Once the pending updates were completed, affected organizations were no longer in an updating state and access to SaaS Manager was restored.
  7. Service Recovery Validated: Technical teams confirmed that access to SaaS Manager had returned to expected operation for affected organizations.

Future Preventative Measures

This incident highlighted the importance of improving resilience, capacity handling, and monitoring for high-volume internal configuration update activity that can affect customer access.

Based on the investigation, the following follow-up activities are being reviewed:

  1. Capacity Handling Review: Review processing behavior for high-volume configuration update activity to reduce the likelihood of pending updates affecting customer access.
  2. Update Process Resilience: Evaluate improvements to how SaaS Manager configuration updates are processed so that customer access is not unnecessarily affected if update activity takes longer than expected.
  3. Monitoring and Alerting Improvements: Review monitoring opportunities to identify large volumes of pending or delayed configuration updates earlier.
Posted May 12, 2026 - 20:53 PDT

Resolved

Incident Description: Earlier today, we experienced an issue affecting Flexera One SaaS Manage in the NAM region. During the impact window, affected customers may have been unable to access the application.

Priority: P1

Impact Start: April 29, 2026, 3:00 AM PDT
Impact End: April 29, 2026, 7:30 AM PDT
Impact Duration: 4 hours and 30 minutes

Restoration Activity: Our technical teams identified the issue and completed the required restoration activities. Access has been restored, and we will continue to monitor the environment to ensure continued stability. A formal retrospective will be conducted to review the root cause, actions taken during the incident, and any long-term preventative measures. A postmortem report summarizing those findings will be shared following the retrospective.
Posted Apr 29, 2026 - 11:33 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US SaaS Manager).