Flexera One- IT Asset Management - NAM - Service unavailable

Incident Report for Flexera System Status Dashboard

Resolved

Service has been restored and is operating normally. Following recovery, technical teams completed extended monitoring and validation activities and have confirmed stable operation. The incident is now considered resolved.
Posted Sep 23, 2026 - 08:57 PDT

Update

The upgrade has been completed successfully, and the site is now back online. Our team is performing final validation checks to confirm service stability before declaring the incident resolved.
Posted Sep 23, 2026 - 06:02 PDT

Monitoring

The upgrade has been completed successfully. Our teams are now working to restore the services and perform post-deployment validation.
Posted Sep 23, 2026 - 04:47 PDT

Update

Our technical teams have completed a major phase of the ongoing maintenance activity and are continuing with the remaining processing required to complete the upgrade. The process is taking longer than originally estimated. The environment remains unavailable while these activities are in progress.

Teams are actively monitoring the remaining processing and evaluating options to restore service as quickly and safely as possible. Further updates will be provided as the upgrade progresses and the restoration timeline becomes clearer.
Posted Sep 23, 2026 - 02:15 PDT

Investigating

Incident Description: We are currently investigating an issue affecting the Flexera One IT Asset Management (ITAM) North America Production environment, which remains unavailable due to scheduled maintenance extending beyond the planned maintenance window. The maintenance activity is still in progress while a database rebuild completes.

Priority: P1

Restoration Activity: Our technical teams are actively working to complete the remaining maintenance activity and restore service as quickly as possible. The ETA for the database rebuild is approximately 2 Hours. Our teams are closely monitoring the progress and will provide further details as they become available.
Posted Sep 22, 2026 - 23:51 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting).