Our investigation and validation efforts to date have not identified any impact to Spot billing or cost analysis data. The billing and pricing data reviewed remains consistent with expected values. While initial validation results are positive, we are continuing additional validation activities as further data becomes available to confirm these findings. We remain engaged with AWS and will continue to monitor the situation closely. We will share additional updates as our validation activities continue.
Posted Jul 17, 2026 - 11:24 PDT
Identified
We continue to closely monitor the service provider outage and its impact on affected services. Further updates will be provided as new information becomes available.
Posted Jul 17, 2026 - 06:14 PDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2026 - 03:27 PDT
Investigating
Incident Description: We have identified an issue impacting billing and cost visibility for AWS customers in all regions. As a result of an active service provider disruption, customers may observe inaccurate, incomplete, or delayed estimated cost and usage information within the Billing and Cost Management Console. This issue is limited to AWS-based services and does not affect customers using other cloud platforms.
Priority: P2
Restoration Activity: Our technical teams have confirmed that the issue is related to an active AWS service event affecting all regions. We are actively monitoring the situation and working closely with AWS updates to assess customer impact. Service restoration is dependent on AWS resolving the underlying issue, and we will continue to provide updates as additional information becomes available.