Flexera One – APAC – Intermittent Access Issues

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One – APAC – Intermittent Access Issues

Timeframe: July 3, 2026, 11:20 AM PDT – July 3, 2026, 11:50 AM PDT

Incident Summary

On July 3, 2026, at approximately 11:20 AM PDT, an issue was identified affecting a subset of Flexera One services in the APAC production environment.

During the incident window, some customers may have experienced intermittent access issues or failures when accessing certain areas of the Flexera One platform. The impact was intermittent in nature, as redundant service capacity remained available and continued serving traffic during the incident. Other Flexera One regions, including NAM and EU, were not impacted.

Technical teams began investigating immediately and reviewed the affected services and supporting platform components within the APAC environment. The investigation identified that a recent change made within the APAC environment was contributing to the intermittent service failures being observed.

As part of the recovery effort, the change was reverted and service behavior was monitored to validate recovery. Following the rollback, service stability was restored and customers were able to access affected functionality normally. By approximately 11:50 AM PDT, services were operating as expected and the incident was considered resolved.

Root Cause

The incident was caused by a configuration change within the APAC environment that unintentionally affected communication between a subset of platform services and a backend platform component.

During the investigation, technical teams determined that the change resulted in certain platform services being unable to communicate properly with the affected component. This led to intermittent failures affecting a subset of Flexera One services in the APAC region.

While the issue was occurring, one or more pods supporting the affected services remained available and continued serving traffic. As a result, customers experienced intermittent access issues rather than a complete service outage.

Remediation Actions

The following actions were taken during the incident response:

• Incident Investigation Initiated: Technical teams began investigating intermittent access issues affecting a subset of Flexera One services in the APAC region.
• Platform Review Completed: Technical teams reviewed the affected services and supporting platform components within the APAC environment to identify the source of the issue.
• Recent Change Identified: Investigation identified a recently implemented change that correlated with the observed service degradation.
• Change Reverted: The identified change was reverted as part of the mitigation effort to restore normal service behavior.
• Service Recovery Validated: Technical teams monitored service behavior following the rollback and confirmed that affected functionality was operating normally.
• Platform Stability Monitoring Continued: Additional monitoring was performed after restoration activities to verify continued service stability before the incident was closed.

Future Preventative Measures

This incident highlighted the importance of validating platform changes to ensure unintended impacts are identified before they affect service availability.

Based on the investigation, the following follow-up activities are being pursued:

• Configuration Validation Improvements: Review and enhance validation processes for infrastructure and platform configuration changes to help identify unintended impacts before changes are implemented in production environments.
• Post-Deployment Verification Enhancements: Review post-deployment verification procedures to ensure critical service dependencies remain accessible and functioning as expected following configuration changes.

Posted Jul 16, 2026 - 23:11 PDT

Resolved

Incident Description: We identified an issue affecting a subset of Flexera One services in the APAC region, which may have resulted in intermittent access issues or failures for some users. The impact was intermittent, and other regions were not impacted. The issue has been resolved, and affected services are operating normally.

Priority: P2

Restoration Activity: Our technical teams investigated the issue and reverted a recent change to restore service. We validated that the affected services are functioning normally and continued monitoring to ensure platform stability. This incident has been resolved.
Posted Jul 03, 2026 - 12:07 PDT
This incident affected: Flexera One - IT Asset Management - APAC (IT Asset Management - APAC Beacon Communication, IT Asset Management - APAC Inventory Upload, IT Asset Management - APAC Login Page, IT Asset Management - APAC Batch Processing System, IT Asset Management - APAC Business Reporting, IT Asset Management - APAC SaaS Manager), Flexera One – APIs – APAC (api.flexera.au), Flexera One - IT Visibility - APAC (IT Visibility - APAC), Flexera One - Cloud Management - APAC (Cloud Cost Optimization - APAC), and Flexera One - Cloud License Management - APAC (Cloud License Management - APAC).