Cloud Cost Optimization (CCO) - EU & NA Regions - Cost Allocation Discrepancies

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One - Cloud Cost Optimization (CCO) - EU & NA - Cost Allocation Discrepancies

Timeframe: March 25, 2025, 5:11 AM PDT – March 25, 2025, 12:12 PM PDT

Incident Summary

On March 25, 2025, at 5:11 AM PDT, a subset of customers using the Cloud Cost Optimization (CCO) platform experienced discrepancies in how costs were allocated within their environments. Specifically, certain charges were not being assigned to the appropriate billing centers as expected. The impact was minimal and limited to specific customers using custom allocation logic.

Technical teams investigated and confirmed that the core CCO platform, including data ingestion and allocation services, was operating as intended. Our initial investigation pointed to allocation rules not being generated as expected in a small number of customer instances. This behavior was not observed elsewhere and later resolved on its own without any changes to the platform, suggesting a brief interruption specific to those customer environments only.

Additional reports from other environments were also reviewed during the investigation. These were found to be unrelated, with cost data determined to be valid and consistent with expected behavior. No broader impact was identified. The incident was marked as resolved on March 25, 2025, at 12:12 PM PDT.

The platform and affected customer environments were monitored for an extended period following resolution, and no further anomalies were observed.

Root Cause

Primary Cause:

In a limited number of customer instances, allocation rules did not appear to be generated as expected during the automated policy process. The platform was functioning normally, and no changes were made during the affected period.

Contributing Factors:

• The behavior was isolated to specific customer instances and resolved without intervention.
• Reported cases resolved on their own, limiting the ability to trace the behavior during investigation.
• Other reports reviewed during the investigation were unrelated and reflected valid, expected data.

Remediation Actions

  1. Validation of Platform Behavior: Core platform functionality was reviewed and confirmed to be operating correctly throughout the incident.
  2. Environment-Level Resolution: Allocation issues observed in affected customer instances were automatically resolved, with no further action required at the platform level.
  3. Clarification of Unrelated Reports: Other reports investigated in parallel were closed out after validation of data accuracy.

Future Preventative Measures

The issue was initially treated with high urgency, and proactive communications were shared while broader impact was assessed. As the investigation progressed, the behavior was confirmed to be limited, with reported cases resolving on their own and no recurring symptoms observed.

  1. Proactive Example Identification if Repeated: While this appears to be a one-time occurrence, we now have a proactive approach in place to capture clear examples, such as an allocation rule that was expected to apply and a corresponding cost entry that was not allocated as intended. This will support faster, more targeted investigation should similar behavior occur again.
  2. Improved Diagnostic Clarity: Internal workflows will be refined to better differentiate between platform-level concerns and isolated behaviors in customer instances, particularly when issues auto-resolve before detailed investigation is possible.
Posted Mar 31, 2025 - 18:35 PDT

Resolved

Upon further investigation, we have identified that the issue was limited to a small subset of customers and did not impact the core functionality of the Cloud Cost Optimization platform. There was no impact to the broader customer base, and the platform continues to function as expected.

The behavior was tied to specific configuration scenarios and has since been addressed. No further issues have been observed, and the overall impact was minimal. This incident is now considered closed.
Posted Mar 25, 2025 - 12:53 PDT

Update

We have confirmed that account metadata is being retrieved successfully, but in some cases, it isn’t being applied as expected during processing. Our teams are reviewing how this data is handled and are looking closely at execution details to isolate where the breakdown is occurring.

We are also comparing behaviors across impacted environments to determine whether the issue is systemic or configuration-specific. Investigation is ongoing and we’ll continue to share updates as progress is made.
Posted Mar 25, 2025 - 11:08 PDT

Update

We are making progress in addressing the cost allocation discrepancies identified in certain configurations. Our team is actively gathering data and conducting tests to resolve the issue effectively. We appreciate your patience and will continue to provide updates as more information becomes available.
Posted Mar 25, 2025 - 09:26 PDT

Update

Our technical teams are actively investigating the issue. We have identified patterns where discrepancies occur under certain configurations, though this isn't consistent across all organizations.​

To assist in resolving this, we are collecting relevant data and conducting internal tests to better understand and address the issue.​

We will continue to provide updates as we make progress.
Posted Mar 25, 2025 - 08:22 PDT

Investigating

Incident Description: We are currently experiencing an issue within the Cloud Cost Optimization (CCO) platform affecting some customers in the EU and NA regions. While the platform remains accessible, this issue may impact the process used to assign costs, leading to some allocations not being performed correctly. As a result, customers may notice incorrect or missing cost allocations in their billing centers.​

Priority: P3

Restoration Activity: Our technical team is actively investigating the root cause of the failures and is working on restoring the correct functionality as swiftly as possible. Comprehensive backend log reviews are ongoing, and we will continue to provide updates as we make progress towards a resolution.

Note: It's important to note that while the platform remains accessible, these allocation issues are isolated and do not indicate a broader system outage.
Posted Mar 25, 2025 - 06:21 PDT
This incident affected: Flexera One - Cloud Management - Europe (Cloud Cost Optimization - EU) and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US).