Flexera One - IT Visibility - NA - Dashboard Access Issues

Incident Report for Flexera System Status Dashboard

Resolved

The issue affecting IT Visibility dashboards in the North America region has been resolved.

Our investigation confirmed that the problem was related to a configuration change in that region. The change has been addressed, and access to dashboards has been restored. Dashboards in other regions were unaffected.
Posted Jul 09, 2025 - 17:17 PDT

Update

Our investigation is ongoing. The service provider has shared an initial observation that the issue may be related to authentication headers missing from incoming requests. We are continuing to investigate this on our side to validate the finding and determine the underlying cause. We will provide further updates as more information becomes available.
Posted Jul 09, 2025 - 16:03 PDT

Investigating

Incident Description: We are currently investigating an issue affecting IT Visibility (ITV) dashboards, potentially impacting a limited set of customers in the North America region. Affected customers may experience issues loading dashboards. Other ITV functionalities, including Power BI dashboards, remain accessible.

Priority: P2

Restoration Activity: Our technical teams are actively engaged and reviewing access for affected customers. Initial findings suggest the issue is limited to legacy dashboard access for a small number of organizations. We are collaborating internally and working with our service provider to identify the root cause. Further updates will be provided as more information becomes available.
Posted Jul 09, 2025 - 15:03 PDT
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US), Flexera One - IT Visibility - Europe (IT Visibility EU), and Flexera One - IT Visibility - APAC (IT Visibility - APAC).