We continue to make progress in addressing the performance issues affecting a subset of customers in the APAC and Europe production environments. The identified fixes have now been deployed, and we are actively monitoring the environment as customer processing activities continue. Our teams are validating the effectiveness of these changes and assessing overall platform performance. We will provide additional updates as more information becomes available.
Posted Jul 17, 2026 - 08:58 PDT
Identified
Incident Description: We have identified an issue affecting inventory processing in Flexera One IT Asset Management following the deployment of the 2026 R1.1 release in our APAC and Europe environments. As a result, a subset of customers may experience degraded performance when accessing certain areas of the user interface and while performing system-related tasks.
Priority: P3
Restoration Activity: Our technical teams have identified the issue as a software defect introduced with the 2026 R1.1 release. Mitigation measures have been implemented to reduce customer impact, and teams are actively working to fully restore service performance. We will continue to provide updates as progress is made.
Posted Jul 17, 2026 - 01:24 PDT
This incident affects: Flexera One - IT Asset Management - Europe (IT Asset Management - EU Inventory Upload) and Flexera One - IT Asset Management - APAC (IT Asset Management - APAC Inventory Upload).